macOSアップデート後にでるbrew caskのエラーを直す
macOSアップデート後にでるbrew caskのエラーを直す

macOSアップデート後にでるbrew caskのエラーを直す

タグ
homebrewmacOSWiresharkcaskbrew
投稿日
Mar 11, 2019
著者
💩 うんち

macOSのアップグレードをしたあと、 brew cask のアップデートがあったときに以下のようなエラーがでることがあります。

$ brew cask upgrade
Error: Cask 'wireshark' definition is invalid: invalid 'depends_on macos' value: ":mountain_lion"

解決するにはエラーが出たアプリを手動で削除してから再インストールする必要があります。

brew cask でインストールしたものの実態は /usr/local/Caskroom/ にあるのでここから削除します。

例えば wireshark であれば /usr/local/Caskroom/wireshark です。

$ cd /usr/local/Caskroom/
$ rm -rf wireshark
$ brew cask install wireshark

これで再インストールできればOKです。